Contrib: Gradebook2
  1. Contrib: Gradebook2
  2. GRBK-1324

Fix lettergrade-import detection restore point-value imports into lettergrade gradebooks

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.0
    • Fix Version/s: 1.8.0-rc4, 1.8.0
    • Component/s: GWT Client
    • Labels:
      None
    • Target Version:
    • QA Status:
      PASS
    • Previous Issue Keys:

      Description

      In the maxpoints conversion dialog listener (which handles the value conversions based on the maxpoints entered by the user), code that attempts to detect the type of data (letter or number) that is imported for an item is not correct and the result is that all imported values are assumed to be letters and so if importing nummbers into LETTERS gradebooks, conversions (appear) to not be done.

      This regular expression is matching all values and the variable is set to TRUE

      {code}
      if (o.trim().matches("^\\w")) {
      importingLetters = true;
      break;
      }
      {code}

      Later that boolean assumeLetterImport (which is currently always TRUE) is used in conjunction with importingIntoLetters (TRUE if the current GradeType == LETTERS) to decide whether to do the actual value conversions.
      {code}
      if(!assumeLetterImport || !importingIntoLetters) {
        .. convert values
      {code}

      IMPACT:
      The effect of this logic is that conversions will only take place on values if the import is into a GradeType that is NOT 'LETTERS'

      This suggests that number-valued imports into LETTERS gradebooks is not working

      If true, the result is no different than what happens in 1.7.0

        Issue Links

          Activity

          Jon Gorrono added a comment -
          This was caused by GRBK-1288

          Dave W is going to test/verify
          Jon Gorrono added a comment -
          Unfortunately, this may be a blocker for 1.8.0 release since the max points value that the user enters is placed into the max points possible for the item immediately making the unconverted values in the file incorrect (if max is not 100)

          That does'nt happen in 1.7.0
          Jon Gorrono added a comment -
           - added preliminary check for orginal score value to use in regular expression match
           - changed regular expression to use character (letter) ranges
           - changed test to run conversion based on what is in the file alone
           - set the minValue of the field validator to 1.0d if file contains letters
           - changed text to not display high/low from file if file contains letters
           - displays AppConstants.gradeTypeLetters() if file contains letters.


          resolving
          David L. Woods added a comment -
          QA Test

          looks good for importing either letters or numbers in the new item template. They both ask for max points, with the letter import defaulting to 1pt so that you can set it to any value, and the number import showing the range and letting you set the value to greater than the maximum in the range.

          Unstructured imports treat all imported numbers as percents, even if the max points in brackets is not 100 -- so point score import in unstructured format only works for max points 100. This is the existing behavior for unstructured imports in production.

          QA PASS

            People

            • Assignee:
              Unassigned
              Reporter:
              Jon Gorrono
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: