Contrib: Gradebook2
  1. Contrib: Gradebook2
  2. GRBK-407

Improper handling of re-import of Scantron grades.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.1.3-b1, 1.3.0-b8, 1.5.0
    • Fix Version/s: 1.5.0-a1, 1.5.0
    • Component/s: Services
    • Labels:
      None
    • Environment:
    • Target Version:
    • QA Status:
      PASS
    • Previous Issue Keys:

      Description

      From Steve Faith:

      "... regarding the re-import of Scantron grades.

      Seems that the issue is when they do re-scoring. This means that a subset of Scantrons get re-evaluated by the machine and a new .xls file is produced.

      When they use Import and give the GB item name as the same name of the existing GB item, the import fails with a message indicating that a GB item with that name already exists. It turns out that re-scoring is a more common practice than we may have initially thought. I think that we need to come up with an easy way to make sure that additional imports can be easily appended/merged with an existing GB item."

      QA SUMMARY:

      On all three sites tested, Importing the original site specific Scantron was completely successful. When attempting to re-import a Scantron file with a subset of changed scores, the following message was generated:

      "The scantron assignment entered has previously been imported. We have changed the assignment name so that it will be imported uniquely. If you wanted to replace the old data, then please change it back."

      This implies that the original Scantron data can indeed be updated, however, upon changing the Scantron file name back to the original, the following message is generated:

      "There is already an existing item called "{specific Scantron file name}" in this category. Please enter a different name for the grade item."

      The request fails and the only remaining option is to cancel (see GRBK-403).

      Is the initial error message in error when it advises that changing the file name back to the original will allow replacing/updating of the original Scantron data?

        Issue Links

          Activity

          Jon Gorrono added a comment - - edited
          The core issue in this jira was fixed in july 2010... the qa failers should have created a new issue...

          The new issue is that there seems to be a difference between initial and regrade scantron file formats.

          The comments in this jira point to that difference being in the header name (being 'test' instead) ... other header labels are also different

          Steve Faith submitted a question to Center for Excellence in Teaching & Learning and the response included the attached xls file (with the student id's redacted).

          If so then the wizard is not needed since all the ui changes were implemented last year... if we want to change the interaction, we should make a new jira.
          Jon Gorrono added a comment -
               -- made header keys and ignored header values injectable
               -- added check for re-score header after failed check for normal scantron header
          David L. Woods added a comment -
          QA Summary

          import a scantron file. change the target item name, max points, and target category on the first import page. finish the import.
          then re-import the same scantron file with some scores changed. change the target item name, max points, and target category to match that of the first import.
          Warning pop-up appears -- "Are you sure you want to overwrite existing assignment(s)? " -- hit the 'overwrite' button and the incoming values overwrite the existing grades.

          QA PASS

          NOTE that the overwritten item drops to the bottom of the category, rather than staying in the original location and the display checkbox is turned off. This was unexpected behavior.

          NOTE GRBK-905 was created to cover the case where the Scantron rescore file has a different column name for the column containing the new scores.

          David L. Woods added a comment - - edited
          QA VERIFICATION on:
           smartsite-dev.ucdavis.edu

          QA ENVIRONMENT:
           Win XP with Firefox 3.6.6

          QA TASK:
          GB2 import function: check if scantron rescore file (the column with scores is titled 'test') allowed to override previously loaded scores (regular scantron file with scores in column titled 'score'.)

          QA RESULTS:
          in a Categories Points gradebook (no weights):

          initial scantron .xls file loaded into new item in GB -- okay -- was able to name the item, set the max points, set the category -- and give a % of category, even though this was not a weighted cats points gradebook. the cat weight is apparently ignored.

          scantron rescore .xls file load attempted into same item in GB -- allowed all the same edits as indicated above. Received a dialogue box asking whether to overlay grades in an existing item. said yes. the new grades were entered in the existing item, overlaying the previous grades.


          History shows the creation of the item on initial import, and import of scores, followed by modification of the item, and import of new scores to replace previously entered ones.

          QA SUMMARY:

          import from Scantron file format (either initial or rescore scantron processing results) into gradebook can use either new or pre-existing item in gradebook structure to receive the scores in smartsite-dev.

          QA PASS

          Note this nullifies the GRBK-905 I created the first time I attempted to test this and failed the item re-use capability.
          Joyce Johnstone added a comment -
          Dave, can this be closed?

          Joyce

            People

            • Assignee:
              Unassigned
              Reporter:
              Vernon O'Connor
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: