Contrib: Gradebook2
  1. Contrib: Gradebook2
  2. GRBK-800

For letter grade GBs, GB2 using both cutoffs from numerical scores sent from other tools (e.g., entered an 89.7 in Forums-F1 and the item in GB2 shows a B+; should be an A- w/ 89.66 cutoff).

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 1.3.0
    • Fix Version/s: None
    • Component/s: GWT Client
    • Labels:
      None
    • Previous Issue Keys:

      Description

      For letter grade GBs, GB2 using both cutoffs (official UCD final grade cutoffs -- ##.99 -- and GB2 letter grade cutoffs -- ##.66) for numerical scores sent from other tools (e.g., entered an 89.7 in Forums-F1 and the item in GB2 shows a B+; should be an A- w/ 89.66 cutoff).

      See my comment below and the attached .jpgs for further explanation.

        Issue Links

          Activity

          Jon Gorrono added a comment - - edited
          The lower cutoff for the '+' grades is not, for example, 86.9 - 87.0 as it is in the default gradescale... the code has a static scale in it for letter grade gradebooks in which the lower cutoff, in the example, is around 86.6666
          Fernando Socorro added a comment -
          For Three, Sakai Student I entered 89.7 for Forums-F1, which should be an A- w/ the 89.66 cutoff, but the item's grade is B+.*

          *The Calculated Grade shows the numerical scores I entered; the only item being counted in the grade is F1.
          Fernando Socorro added a comment -
          Sorry, yes, Jon, you are correct, but the issue is that GB2 seems to be using both cutoffs from grades sent from other tools. So far I tried Assignments & Forums, do not think it is necessary at this point to try T&Q, but can do that, too. The site w/ the Forums and Assignments I was working on is -GB Letter grade tools.

          See the attachments re the descriptions below:
          1. In attachment 1 -GB Letter grade tools GRBK-800.jpg, for Three, Sakai Student I entered 89.7 for Forums-F1, which should be an A- w/ the 89.66 cutoff, but the item's grade is B+.*
          2. In attachment 2 -GB Letter grade tools GRBK-800.jpg, you can see
              a. for Five, Sakai Student, I entered 79.7 for Forums-F2, which should be a B- w/ the 79.66 cutoff, but the item' grade is a C+.**
              b. for Two, Sakai Student, I entered 69.7 for Forums-F2, which should be a C- w/ the 69.66 cutoff, but the item' grade is a D+.**

          * The Calculated Grade shows the numerical scores I entered; the only item being counted in the grade is F1.
          **The Calculated Grade shows the numerical scores I entered; the only item being counted in the grade is F2.

          Note: As per David Woods' request, for comparison I also uploaded attachment 3 -GB Letter grade tools GRBK-800.jpg, the official UCD Grade Scale.
          Fernando Socorro added a comment -
          Please note I changed the description to better illustrate what I encountered.

          Let me know if I need to make any further edits.

          ~F
          Fernando Socorro added a comment -
          Updated for clarity. Will pass on to Tim K to review.
          Jon Gorrono added a comment -
          I think the problem here is really that the displayed scale is not the one being used.... if not *the problem* (still have to realize some of what Fernando is pointing out) then it a contributing factor for confusion.
          Joyce Johnstone added a comment -
          Thomas or Jon - I don't know what the solution is for this?

          Joyce
          Thomas Amsler added a comment -
          For a letter grade gradebooks the percentage grade to letter grade lookup uses the following cutoffs:

          A+ range 96.6666666666 to 100
          A range 93.3333333333 to 96.6666666666
          A- range 90.0000000000 to 93.3333333333
          B+ range 86.6666666666 to 90.0000000000
          B range 83.3333333333 to 86.6666666666
          B- range 80.0000000000 to 83.3333333333
          C+ range 76.6666666666 to 80.0000000000
          C range 73.3333333333 to 76.6666666666
          C- range 70.0000000000 to 73.3333333333
          D+ range 66.6666666666 to 70.0000000000
          D range 63.3333333333 to 66.6666666666
          D- range 60.0000000000 to 63.3333333333
          F range 0.0000000000 to 60.0000000000

          The other way around, letter grades are converted to percentage values using this map:
          A+ --> 98.3333333333
          A --> 95
          A- --> 91.6666666666
          B+ --> 88.3333333333
          B --> 85
          B- --> 81.6666666666
          C+ --> 78.3333333333
          C --> 75
          C- --> 71.6666666666
          D+ --> 68.3333333333
          D --> 65
          D- --> 61.6666666666
          F --> 58.3333333333
          0 --> 0

          Jon Gorrono added a comment -
          please re-evaluate with the above scale..
          Fernando Socorro added a comment -
          See attached .jpg: GRBK-800 01-27-11.jpg

          Now, with all the proper info, I got it to work just fine. In discussing this with David we agreed that the documentation needs to be made as succinct as possible to avoid confusion. Especially important is to have the letter grade Grade Scale reflect the calculations, which as of now it does not.
          NOTE: I do have a concern with the grade scale included in this ticket. As an example I entered a 60.00 for yzqbn and got a D-. The cutoff in the scale above says:
          D- range 60.0000000000 to 63.3333333333
          F range 0.0000000000 to 60.0000000000
          To me, this is confusing. Is the cutoff really:
          D- range 60.0000000000 to 63.3333333333
          F range 0.0000000000 to 59.9999999999
          And so on, Because as of now the lower and upper cutoffs for each grade are the same.
          Hope this is clear. Lemme know if you need anymore info.
          Joyce Johnstone added a comment -
          Displaying the proper grade scales for specific gradebook types needs to be addressed in a future release. This will not be included in the v1.4.0 release.
          Joyce Johnstone added a comment - - edited
          Discussion of possible requirements:
          1. Investigate having GB2 block submissions from other tools if it's letter grade gradebook
          2. Investigate individual tools that do grading; do not show submit to gradebook option for letter gradebooks (this may be a big effort)
          3. Consider completely implementing the simple grade mode (A,B,C....) in addition to plus/minus (A+/-, B+/-....)
          4. Short term fix is to hide the option of using simple letter grading (would also include #7)


          Thomas Amsler added a comment -
          Created GRBK-858, which outlines specifications for GRBK-704 and GRBK-803

            People

            • Assignee:
              Unassigned
              Reporter:
              Fernando Socorro
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: