Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-38968

Admin Worksite Setup - Unpublished sites not appearing in list

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: CLOSED
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.8.x, 2.9.x
    • Fix Version/s: 2.9.x
    • Component/s: Kernel
    • Labels:
    • Environment:
    • Previous Issue Keys:
      SAK-21186, KNL-897

      Description

      While experimenting on the nightly server (http://nightly2.sakaiproject.org:8082/portal/), I noticed that a new site I created as "unpublished" was not appearing at all in My Workspace > Worksite Setup. It was appearing as a "tab" up top, since I called the site "A test site" so it was alphabetically available. However, it should also be listed in the "Worksite Setup" area since an admin should be able to view all sites, not just published sites. (Like a faculty member can see his/her published and unpublished sites if they are the site owner/maintain/instructor role.)

      I opened a new browser and could reproduce the behavior. I logged out and logged back in and it still happened. I created a new site ("A test site 2"), also unpublished, and it wasn't listed either. I created another ("A test site 3"), this one published, and it did appear in the list.

      Please see the screenshot for the visual.

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  buckett Matthew Buckett
                  Reporter:
                  alanregan Alan Regan
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration