Uploaded image for project: 'Lesson Builder'
  1. Lesson Builder
  2. LSNBLDR-840

Lessons - "Add Question" - Show Poll Results Does Not Work

    Details

    • 11 status:
      Resolved
    • Test Plan:
      Hide

      Steps to replicate issue:

      1. Visit https://trunk-mysql.nightly.sakaiproject.org and create at least two accounts (one as instructor and one as student)
      2. As instructor, create a project site, add common tools, especially Gradebook or Gradebook Classic (doesn't matter which – problem happens with either tool).
      3. Go to Lessons
      4. "Add Content" > "Add Question"
      5. Create a simple question, e.g. "Did you do the assignment?"  Two answers "Yes" and "No."  Mark "Yes" right.  Select to show results and add to Gradebook. Give it a title for the Gradebook (e.g. "Lessons Question Test") and make it worth 10 points. Put in "Great!" for the correct answer and "Why not?" for incorrect.
      6. Enroll the student account into the site.
      7. Logout and log in as the test student account.
      8. Go to Lessons. Answer the poll. Click "Show Poll."
      9. No results (0 Yes, 0 No)
      10. However, if instructor looks at the Gradebook or uses the "Show Grading Pane" in Lessons, the answers are recorded correctly.

      *********************************

      Show
      Steps to replicate issue: Visit https://trunk-mysql.nightly.sakaiproject.org  and create at least two accounts (one as instructor and one as student) As instructor, create a project site, add common tools, especially Gradebook or Gradebook Classic (doesn't matter which – problem happens with either tool). Go to Lessons "Add Content" > "Add Question" Create a simple question, e.g. "Did you do the assignment?"  Two answers "Yes" and "No."  Mark "Yes" right.  Select to show results and add to Gradebook. Give it a title for the Gradebook (e.g. "Lessons Question Test") and make it worth 10 points. Put in "Great!" for the correct answer and "Why not?" for incorrect. Enroll the student account into the site. Logout and log in as the test student account. Go to Lessons. Answer the poll. Click "Show Poll." No results (0 Yes, 0 No) However, if instructor looks at the Gradebook or uses the "Show Grading Pane" in Lessons, the answers are recorded correctly. *********************************

      Description

      PROBLEM:

      Student answers a "question" in Lessons that is linked to the Gradebook and clicks the "Show Poll" button.  The poll is empty – no responses.

      See test plan in Testing tab for more details to replicate.

      Interesting side note.  If a question is added and not linked to the Gradebook, but the "show results" is not selected initially.  A student takes poll.  Professor corrects the setting and turns on the results.  The poll results only display the results after the show results was checked, not before.  Example: ask question about favorite color, options Blue, Red, Green, and Yellow.  No right answer, not linked to Gradebook.  Not set to show results initially. Sample Student 1 answers question.  Instructor returns to question, changes results setting to display results.  Sample Student 2 answers question, that person's result is shown, but not the previous student. Any subsequent students will see the aggregate answers from Student 2 on, but not Student 1's answer in the mix. Happy to create a separate JIRA, but offering this wrinkle in case it helps diagnose the issue.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  drramsey Derek Ramsey
                  Reporter:
                  alanregan Alan Regan
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: