Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-24846

Special characters in titles, short description do not display correctly

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Verified
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.0
    • Fix Version/s: 10.0
    • Component/s: Messages Tool
    • Labels:
    • Environment:
      FF/Chrome on OSX
    • Previous Issue Keys:
      MSGCNTR-822

      Description

      Steps to reproduce:

      In Forums, start a new conversation
      In conversation title box, enter:

      " " & < >

      Save new conversation. Title does not display correctly (see screenshot).

      Confirmed in nightly (http://nightly2.sakaiproject.org:8087/portal) and on 2.9 production instances. Confirmed not an issue in 2.8 prod instance.

      Perhaps related to: https://jira.sakaiproject.org/browse/MSGCNTR-740
      That JIRA is for an issue with special characters in forum/topic titles, but the above special characters only caused an issue in conversation titles. However, the example used in MSGCNTR-740 ("<g<g<g<g<g") still caused display issues (only one quote mark displayed).

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  baholladay Bryan Holladay
                  Reporter:
                  jmezz Jim Mezzanotte
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  8 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration