We've had users confuse the option to hide a folder (accessible under "Revise" or "Revise Details") with the "hidden" permission. They expected that checking "Hidden" under "Permissions" would make that item "hidden", in fact it has the opposite effect and prevents the item from being hidden (since it actually turns on the ability for that role to change the hidden property, and to do that they must always be able to see the item).
The terminology should be changed to avoid the confusion. It would be better to have an active verb as the permission name - for example "change.hidden" or "allow.hiding" – to better indicate that what you are toggling is the ability to act on an item.
This is really just one symptom of a UI design flaw in Sakai. Really the entire "Permissions" screen in every tool should be reworked to better express what each permission does. The end user should never see the permission name, they should see a permission description.