Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-12060

Uploaded files not using UTF-8 Unicode encoding do not display properly

    XMLWordPrintable

    Details

    • Type: Feature Request
    • Status: CLOSED
    • Priority: Minor
    • Resolution: Non-Issue
    • Affects Version/s: trunk
    • Fix Version/s: None
    • Labels:
      None

      Description

      If a text or html file is uploaded which contains Unicode characters, but not UTF-8 encoding, it will not be displayed correctly if the user attempts to "Edit Content" in resources. Only UTF-8 encoding is typically supported in web applications.

      There isn't an easy solution (that I can think of). Some possibiities:
      1) Test for correct encoding on files when uploaded or edited – but this would likely be unacceptably slow.
      2) Always display a warning in the edit window that non-UTF-8 content will not be displayed correctly.

      One way to reproduce this problem is to create a MS Word document with non-Latin characters, and save as Unicode Text UTF-16).

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  Unassigned Unassigned
                  Reporter:
                  bkirschn Beth Kirschner
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration