Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-15874

Switch to Java 1.6 (Java 1.5 EOL 30-Oct-2009)

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 2.8.0
    • Fix Version/s: None
    • Component/s: Global
    • Labels:
      None

      Description

      Java 1.5 is approaching its End-of-Life (EOL), which is scheduled for 30-Oct-2009:

      http://java.sun.com/javase/downloads/index_jdk5.jsp

      http://java.sun.com/products/archive/eol.policy.html

      For Sakai 2.5 and Sakai 2.6 (which currently is being QA'ed for release with Java 1.5) this means a switch to Java 1.6 at some point during their maintenance cycle.

      For Sakai 2.7, which is tentatively scheduled for code freeze in late 2009, this means we should start thinking about switching development of trunk/2.7 to using Java 1.6, and when it enters QA, it will be QA'ed with Java 1.6.

      For Sakai 3.0, which is still early in development, this likely also means a switch in development and QA to Java 1.6 at some point soon.

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            George Pipkin added a comment -

            I have tried compiling 2.5.x with Java 1.6 and I ran into the JJDBC error as well:

            [INFO] Compilation failure
            /Volumes/MacExt_SAK-1367/sakai/trunk/sam/samigo-services/src/java/org/sakaiproject/spring/DataSourceWrapperAutoCommit.java:[36,7] org.sakaiproject.spring.DataSourceWrapperAutoCommit is not abstract and does not override abstract method isWrapperFor(java.lang.Class<?>) in java.sql.Wrapper

            This happened AFTER changing the settings.xml file to include the line:
            .........
            <maven.test.skip>true</maven.test.skip>
            </properties>

            • George Pipkin
              U.Va.
            Show
            George Pipkin added a comment - I have tried compiling 2.5.x with Java 1.6 and I ran into the JJDBC error as well: [INFO] Compilation failure /Volumes/MacExt_ SAK-1367 /sakai/trunk/sam/samigo-services/src/java/org/sakaiproject/spring/DataSourceWrapperAutoCommit.java: [36,7] org.sakaiproject.spring.DataSourceWrapperAutoCommit is not abstract and does not override abstract method isWrapperFor(java.lang.Class<?>) in java.sql.Wrapper This happened AFTER changing the settings.xml file to include the line: ......... <maven.test.skip>true</maven.test.skip> </properties> George Pipkin U.Va.
            Hide
            Seth Theriault added a comment -

            The description of this bug probably needs to be updated to exclude 2.5 and 2.6 from Java 1.6 consideration. These releases are out the door and I think it is unlikely they will be modified further for 1.6 compatibility.

            Show
            Seth Theriault added a comment - The description of this bug probably needs to be updated to exclude 2.5 and 2.6 from Java 1.6 consideration. These releases are out the door and I think it is unlikely they will be modified further for 1.6 compatibility.
            Hide
            David Horwitz added a comment -

            Maintenance team review: If this issue is being worked on please take ownership of it by assigning it to yourself. Otherwise it is likely to be closed as an abandoned issue. If this is not being pursued please close the issue.

            Show
            David Horwitz added a comment - Maintenance team review: If this issue is being worked on please take ownership of it by assigning it to yourself. Otherwise it is likely to be closed as an abandoned issue. If this is not being pursued please close the issue.
            Hide
            Jean-François Lévêque added a comment -

            I thought this issue was still a community goal.

            Show
            Jean-François Lévêque added a comment - I thought this issue was still a community goal.
            Hide
            Alan Berg added a comment -

            Closed as per request of Release managemenet meeting to be reopened for affect version 2.8. Currently two options set in JAVA_OPTS to allow running under Java 1.6

            Show
            Alan Berg added a comment - Closed as per request of Release managemenet meeting to be reopened for affect version 2.8. Currently two options set in JAVA_OPTS to allow running under Java 1.6

              People

              • Assignee:
                Unassigned
                Reporter:
                Peter A. Knoop
              • Votes:
                3 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development