Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-18801

Links directly to tools/pages/on sites don't work when portal autoforwards to PDA portal

    Details

    • Type: Bug
    • Status: CLOSED
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 2.7.2, 2.8.0
    • Component/s: Mobile Devices, Portal
    • Labels:
      None
    • CLE Team Issue:
      Yes

      Description

      Direct links to tools/pages on sites that would normally work, eg:
      http://localhost:8081/portal/site/25589f0b-97f8-4371-a272-b114d3940700/page/27b8e036-d7dc-4466-8d3a-94f92711e3fc

      do not work if the portal intercepts and redirects to the PDA portal (introduced in SAK-18720). The display is all mucked up. In the screenshot, I grabbed the link to the wiki in a site then opened in it a mobile device that is automatically forwarded. The title of the tool is rendered above the header and the display seems to render the site list in the iframe?

      Compare to the URL if navigating directly, using the PDA portal:
      http://localhost:8081/portal/pda/25589f0b-97f8-4371-a272-b114d3940700/tool/5c39a658-52e2-4134-b688-f510c13032f6

        Gliffy Diagrams

          Zeplin

            Attachments

              Activity

                People

                Assignee:
                zqian Zhen Qian
                Reporter:
                steve.swinsburg Steve Swinsburg
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    Git Integration