Sakai
  1. Sakai
  2. SAK-18932

Drop box options prevent Instructor from sending email notifications when the "send an email notification to student" is checked (design discrepancy)

    Details

    • Type: Bug Bug
    • Status: Verified Verified
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.2, 2.7.0, 2.8.0, 2.8.1, 2.8.3, 2.9.0, 2.9.1
    • Fix Version/s: 2.9.4 [Tentative], 10.0-qa01
    • Component/s: Drop box
    • Labels:
      None
    • 2.9 Status:
      Merge
    • Previous Issue Keys:

      Description

      At UMich, instructors are reporting that students are not receiving email notifications when the "Send an email notification to student" box is checked in the file upload UI. Investigating the issue reveals that the Drop Box Notifications options are set by default to "Do not allow notifications to be sent". The problem is that the instructor is still shown the "Send an email notification to student" check box and is given no indication that checking this box will NOT send the expected notification, nor are they given any indication that it is necessary to enable this function in the Options UI. In effect, this is broken functionality to the user as the instructor is being mislead into believing that they are able to use a function that is disabled by default.

      I offer the following suggestions for addressing this issue:

      1) When Drop Box Notifications options are set to "Do not allow email notifications to be sent", the text for the "Send an email notification to student" check box should be grayed out to indicate that this function is disabled. (optional: a text snippet indicating that it can be enabled under "options")

      2) When Drop Box Notifications options are set to "Always send email notifications", the "Send an email notification to student" check box should not appear in the UI - Why would you need to check a box to select a behavior that will occur regardless of whether the box is checked? (optional: a text snippet indicating that ability to send student notifications can be enabled under "options")

      3) Alternatively, some text indicating the status of the notification options could appear in the file upload UI, e.g., Student email notifications are currently set to "Do not allow email notifications to be sent".

        Issue Links

          Activity

          Matthew Jones added a comment -
          It looks like (2) works for the root folder of dropbox but not for the subfolders. So it seems like this task would be to.

          For "Always send" hide the option for sub folders (already happens on the root folder)
          For "Do not allow" put a message there indicating that an option exists to enable notifications
          For "Allow", do nothing, as it's already correct
          Trisha Gordon added a comment -
          This issue also affects 2.8.1.
          Trisha Gordon added a comment -
          This issue is also described in SAK-21220, which says it's a duplicate of SAK-18443, but IMHO, it's a duplicate of this Jira.
          David Haines added a comment - - edited
          The attached patch fixes the underlying implementation bug of incorrectly displaying the "send email" box when the box doesn't make a difference. A separate Jira is being created as a feature request to address the UI issue of how best to show whether or not the email will be sent when the dropbox option does not allow the user to choose on a case by case basis. That feature request jira is: https://jira.sakaiproject.org/browse/SAK-23593

          The fix attached here has been tested against 2.9.1 and 2.10 trunk and has been merged to trunk.
          Beth Kirschner added a comment -
          Verified by JZ in May

            People

            • Assignee:
              David Haines
              Reporter:
              Jeff Ziegler
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: