Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-19117

Processing of email templates is failing

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 2.8.0
    • Component/s: Email Template Service
    • Labels:
      None
    • CLE Team Issue:
      Yes

      Description

      I have a simple XML template:

      <?xml version="1.0" encoding="UTF-8"?>
      <emailTemplate>
      <subject>123</subject>
      <message>456</message>
      <htmlMessage>test</htmlMessage>
      <locale>en</locale>
      <version>1</version>
      <owner>admin</owner>
      <key>test</key>
      </emailTemplate>

      However ETS isn't parsing it properly:

      2010-09-09 14:22:43,944 WARN main org.sakaiproject.emailtemplateservice.service.impl.EmailTemplateServiceImpl - Error processing template: 'org/sakaiproject/profile2/emailtemplates/test.xml', class org.simpleframework.xml.core.ElementException:Element 'subject' does not have a match in class org.sakaiproject.emailtemplateservice.model.EmailTemplate at line 3. Skipping ...

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  dhorwitz David Horwitz
                  Reporter:
                  steve.swinsburg Steve Swinsburg
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: