Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-20089

Require Java 1.6

    Details

    • Type: Task
    • Status: CLOSED
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.9.0
    • Fix Version/s: 2.9.0
    • Component/s: Install/Upgrade
    • Labels:
      None

      Description

      This is a parent issue to track the work for requiring Java 1.6 in Sakai 2.9.

      From the list:

      DH:
      2.8: recommend 1.6 - code compiles in 1.5
      2.9: require 1.6 - no guarantee that code will compile/run in 1.5

      AW:
      If we want to drop 1.5 then we need to make sure that the
      code compiles after adjusting Maven's compiler plugin
      settings from 1.5 to 1.6. Last time I checked (early
      December) the kernel failed to build due to an issue with
      kernel util's validater.java due to "unmappable character
      for encoding UTF-8 (53 cases)."

      SS:
      Yep lets get any required modifications committed into trunk, and enforce 1.6 as soon as possible so we can iron anything out early.

      JFL:
      Let's make this a 2.9 blocker and work on this at least as soon as 2.8.0 is released.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  ottenhoff Sam Ottenhoff
                  Reporter:
                  steve.swinsburg Steve Swinsburg
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Git Source Code