Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-21265

Fix all Sakai JSPs so we do not need to use -Dorg.apache.jasper.compiler.Parser.STRICT_WHITESPACE=false

    Details

      Description

      Add the following JAVA_OPTS setting to the release notes for 2.9:

      -Dorg.apache.jasper.compiler.Parser.STRICT_WHITESPACE=false

      At least one JSF tool (forums) requires it when running it in Tomcat 7.

      http://tomcat.apache.org/tomcat-7.0-doc/config/systemprops.html

      Matt Jones: "There were one more strict changed to be true between 5.5 & 7.0 org.apache.jasper.compiler.Parser.STRICT_WHITESPACE
      (If false the requirements for whitespace before an attribute name will be relaxed so that the lack of whitespace will not cause an error. Default is the spec value which is true)

      Perhaps because the code isn't <%@ include or using <jsp:include there it's causing an error now?"

      Matt's suspicion was confirmed by David Horwitz.

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  ottenhoff Sam Ottenhoff
                  Reporter:
                  arwhyte Anthony Whyte
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration