Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-21271

Change edu-services <parent> from sakai-standard-tool to sakai-commons-tool

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: CLOSED
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 2.8.2, 2.9.0
    • Component/s: edu-services, Maven
    • Labels:
      None
    • CLE Team Issue:
      Yes

      Description

      edu-services has a dependency on archive-api. Update parent to sakai-commons-tool and eliminate the local property <sakai.common.version> as this can be inherited from the new commons <parent>.

      <dependency>
      <groupId>org.sakaiproject.common</groupId>
      <artifactId>archive-api</artifactId>
      <version>${sakai.common.version}</version>
      <scope>provided</scope>
      </dependency>

      An even better approach is to move the common archive-api dependency into the <dependencyManagement> element of sakai-commons-tool. edu-services can then drop it from it's <dependencyManagement> element as redundant.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  arwhyte Anthony Whyte
                  Reporter:
                  arwhyte Anthony Whyte
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Git Source Code