Sakai
  1. Sakai
  2. SAK-21524

Stack Trace in Matrices and Evaluations when Evaluator is not in course site with linked assignment

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.9.0
    • Fix Version/s: 2.9.0
    • Labels:
      None
    • Environment:
      sakai-2.9.0-a03, Server qa3-us
      Win7, IE9, FF7
    • 2.9 Status:
      Resolved
    • Previous Issue Keys:

      Description

      Assignment linked to matrix, bug report when evaluator is only in portfolio site, not course site
      Student submits cell for evaluation but student also submitted assignment to matrix cell

      Evaluator is only in the portfolio site, not the course site
      An assignment from the course site is linked to the portfolio matrix
      Student submits assignment to matrix cell from course site
      Student then submits matrix cell in portfolio site for evaluation

      Evaluator clicks on Evaluations link in portfolio site
      If the only evaluation submission is from the student who is also in the course site, the evaluator is not able to see the Evaluations page, but gets bug report
      If another student submits to a matrix that is not linked to the course site, then the evaluator is able to view the Evaluations page


      To reproduce the error:
      In a course site, add students 3,4 and 5
      In a portfolio site, add students 1,2 and 3
      Add evaluator in portfolio site
      Create or import 2 matrices into the portfolio site, make sure evaluator role is chosen for evaluations
      For one of the matrices, click the 'Manage Site Associations' link at the top of the page.
      Click the 'Add' link beside the course site with students 3,4 and 5

      In the course site, create an assignment and post it
      Click on the 'Create/Edit Matrix Links' link and link the assignment to the matrix cell.

      As student3, submit assignment through course site
      Then log into the portfolio site, fill out reflection for the same cell and submit for evaluation

      As evaluator, click on the Evaluations link in the menu
      Bug report displays

      Log in as student and submit cell for evaluation for matrix that is not linked to course/assignment
      As evaluator, click on Evaluations link in menu
      Now evaluator is able to view Evaluations page

      Port1: http://qa3-us.sakaiproject.org:8086/portal/site/fbe21b36-3961-4069-a300-d10397340065/page/152ac1b5-d158-47cd-98cf-1eb5bafc2b0b
      Course 1 a Fall 2010: http://qa3-us.sakaiproject.org:8086/portal/site/ebc6fe27-8fcc-4680-9b4d-27f104037558/page/920ae648-94d2-4083-bc88-aeba579d734d


      Attaching bug report
      1. Evaluator_BugReport.txt
        8 kB
        Andrea Schmidt
      2. SAK-21524.patch.txt
        3 kB
        Yuki Yamada

        Issue Links

          Activity

          Andrea Schmidt added a comment -
          verified on sakai/trunk on Oracle - Built: 08/15/12 08:00 - Sakai Revision: 111467 (Kernel 1.4.0-SNAPSHOT)- Server sakai-nightly.uits.iupui.edu
          Andrea Schmidt added a comment -
          Assume I should click the 'Tested' button since I verified this
          Sam Ottenhoff added a comment -
          2.9.x merge: r112290
          Hudson CI Server added a comment -
          Integrated in assignment 2.9.x #46 (See [http://builds.sakaiproject.org:8080/job/assignment%202.9.x/46/])
              SAK-21524 merge r111458 from trunk (Revision 112290)

               Result = SUCCESS
          Hudson CI Server added a comment -
          Integrated in taggable 2.9.x #28 (See [http://builds.sakaiproject.org:8080/job/taggable%202.9.x/28/])
              SAK-21524 merge r111458 from trunk (Revision 112290)

               Result = SUCCESS

            People

            • Assignee:
              Chris Maurer
              Reporter:
              Andrea Schmidt
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: