Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-222

Rename in resource tool not reflected in webdav

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Content
    • Labels:
      None
    • Environment:
      XP-SP2: IE6, Netscape 7.2, Mozilla Firefox

      Description

      renaming an item (File or folder) in the My Workspace resources area does not update to users WebDAV folder, even upon refresh.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              mmmay Megan May added a comment -

              Please let me know when this is resolved- mmmay@indiana.edu. Falcon ticket IM189651 will need to be updated.

              lance@indiana.edu Lance Speelmon added a comment -

              This could be a bug with Windows XP's webdav client. It seems to be caching the old file name somehow. I have confirmed this behavior is reproducible.

              lance@indiana.edu Lance Speelmon added a comment -

              webdav may be displaying file id instead of title.

              ggolden@umich.edu Glenn R. Golden added a comment -

              This might be because a) the resource's id is shown in webDav, not it's title, and b) the resource's id is set to the upload file id and is never changed. Rename is "re-title", and does not change the resource id.

              mmmay Megan May added a comment -

              What Glenn says makes sense. Renames on the network space actually update the file name in storage.

              If a user uploads a file via WebDAV, the default title is the document name. If a user uploads a file using the web interface and doesn't specify a title, the doc name becomes the title.

              Somehow, it needs to be apparent that changing the title field in Resources doesn't change the document name. I was thinking it'd be great if we could force the title to be the documents name . .

              The typical user won't easily distinguish between document name vs title.

              lance@indiana.edu Lance Speelmon added a comment -

              This will not be addressed for the 2.0 release. However, we do have a completely revamped resources tool slated to move into production this summer. If things go according to plan, this issue will be addressed.


                People

                • Assignee:
                  Unassigned
                  Reporter:
                  mmmay Megan May
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Git Source Code