Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-23630

Move to supported LDAP library

    Details

    • Type: Feature Request
    • Status: RESOLVED
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.1, 11.4, 12.3
    • Fix Version/s: 19.0
    • Component/s: Providers
    • Labels:
      None
    • 12 status:
      Please Merge

      Description

      The JLDAP library is not well supported and doesn't have very good performance.

      http://www.dirmgr.com/blog/2011/5/31/comparing-java-ldap-sdk-performance.html

      The unbound ID library is license compatible with Sakai, is actively developed and has much better performance.

      https://www.unboundid.com/products/ldapsdk/
      http://search.maven.org/#browse%7C185309113

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  ottenhoff Sam Ottenhoff
                  Reporter:
                  buckett Matthew Buckett
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  9 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration