Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-23738

Upgrade user Admin Preferences Tool to use jsf 1.1_02

    XMLWordPrintable

    Details

    • Type: (Deprecated) Contributed Patch
    • Status: RESOLVED
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.1
    • Fix Version/s: 10.0
    • Labels:
      None
    • 2.9 Status:
      Merge

      Description

      This patch is contributed to remove duplicate jsf 1.1 jars from being deployed to tomcat for the 'user' project.

      UVa noticed duplicate jsf jars in our 2.9.1 Sakai tomcat webapps directory:
      ./webapps/sakai-user-tool-admin-prefs/WEB-INF/lib/jsf-api-1.1.01.jar
      ./webapps/sakai-user-tool-admin-prefs/WEB-INF/lib/jsf-api-1.1_02.jar
      ./webapps/sakai-user-tool-admin-prefs/WEB-INF/lib/jsf-impl-1.1.01.jar
      ./webapps/sakai-user-tool-admin-prefs/WEB-INF/lib/jsf-impl-1.1_02.jar

      This contributed patch removes the older 1.1.01 jars.

      See also: https://jira.sakaiproject.org/browse/SAK-19282

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  aaronz Aaron Zeckoski (Inactive)
                  Reporter:
                  cmw6s Cynthia Gast
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration