Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-23832

New Site Info->Edit Tools: administratiion workspace manually added tools get removed when saving tool list

    Details

    • Type: Bug
    • Status: CLOSED
    • Priority: Blocker
    • Resolution: Incorporated
    • Affects Version/s: 10.0
    • Fix Version/s: None
    • Component/s: Site Info
    • Labels:

      Description

      Manually added tools through the Administration Workspace->Sites tool, which isn't listed in the list of tools in Site Info->Edit Tools, get removed when a user goes in to Site Info->Edit Tools and makes changes.

      To reproduce (in trunk)

      -Create a site
      Go to Administration Workspace>Site Tools and find the new site
      Add a tool to that site which isn't listed in the Site Info>Edit Tools list (in trunk, I picked Lessons since it wasn't in the list)
      -Go to the new site, notice that your tool you added is there
      Go to Site Info>Edit Tools and just click save (notice that the tool you added isn't listed)
      -After saving, you will see that the tool is now removed from the site.

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  bkirschn Beth Kirschner
                  Reporter:
                  baholladay Bryan Holladay
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration