Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-24935

Response to Response permission not working correctly

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: CLOSED
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.7.1
    • Fix Version/s: None
    • Component/s: Messages Tool
    • Labels:
      None
    • Previous Issue Keys:
      MSGCNTR-372

      Description

      Steps to Replicate
      -------------------------------------
      1) Add Forums to project site, add a sample access user "student1"
      2) Go to Site Info -> Manage Groups -> Add new Group called "group1" -> Add student1 to group1
      2) Create new Forum
      3) Create new Topic -> Edit Topic Settings
      4) Remove all permissions from role: access
      5) Add ability to "group1" to "Response to Response"
      6) Create a sample thread in the topic

      Our expectation now is that student1 (part of group1) should be able to respond to a thread but not create a new one

      6) Login as student1
      7) Go to forums -> topic -> thread
      8) Attempt to respond

      Result: Alert: Insufficient privileges to post a thread to topic

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  ottenhoff Sam Ottenhoff
                  Reporter:
                  ottenhoff Sam Ottenhoff
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration