Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-26418

Cannot vote in polls using EntityProvider

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: CLOSED
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.6.0, 2.6.1, 2.6.2, 2.7.0
    • Fix Version/s: 2.6.3, 2.7.1, 2.8.0
    • Component/s: Polls
    • Labels:
      None
    • Previous Issue Keys:
      SAK-18856, POLL-54

      Description

      The PollVoteEntityProvider doesn't seem to be working.

      I have posted this JSON:

      {"pollId": 1", pollOption": 3 }

      to:
      /direct/poll-vote.json

      and I get this response:
      Poll Id must be set to create a vote.

      Debugging the PollVoteEntityProvider shows that the Vote object isn't set.

      log.debug("vote:" + vote.toString());

      gives
      vote:null:null:null:null

        Gliffy Diagrams

          Attachments

          1. eb-tester.zip
            26 kB
          2. SAK-18856-26x.patch
            6 kB
          3. SAK-18856-trunk.patch
            5 kB

            Issue Links

              Activity

                People

                • Assignee:
                  dhorwitz David Horwitz
                  Reporter:
                  steve.swinsburg Steve Swinsburg
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Git Source Code