Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-26723

Only Me privacy settings for staff info not honored

    Details

    • Type: Bug
    • Status: CLOSED
    • Priority: Major
    • Resolution: Incorporated
    • Affects Version/s: 2.8.2
    • Fix Version/s: None
    • Component/s: Profile
    • Labels:
      None
    • Environment:
      sakai-2.9.0-b05 (Kernel 1.3.0-b04)- Server qa3-us
      http://qa3-us.sakaiproject.org:8086/portal/site/
      Win7: IE9, FF12, Safari
    • Previous Issue Keys:
      PRFL-731

      Description

      Setting Profile -> Privacy -> Staff Info to 'Only Me' still allows connections to view the staff info. As the 'connection', I have cleared the browser cache, restarted the browser and even logged in using a different browser and I am still able to see user1's staff info.

      Staff Info -> Only My Connections works fine

      To reproduce:
      Make sure User1 and User2 are connected.

      User1: Fill out the staff info under My Profile
      Click on Privacy
      Select 'Only Me' beside Staff Info

      User2: Log in and click on Profile
      Click on User1 under 'My connections'
      User1's staff information is available

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  steve.swinsburg Steve Swinsburg
                  Reporter:
                  agschmidt Andrea Schmidt
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration