Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-27663

Built in RWiki search not working when search tool enabled

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: OPEN
    • Priority: Critical
    • Resolution: Unresolved
    • Affects Version/s: 10.0, 11.0, 12.0, 19.0
    • Fix Version/s: None
    • Component/s: Search
    • Previous Issue Keys:
      SAK-26571, SRCH-133

      Description

      In trunk(http://nightly2.sakaiproject.org:8082/portal), Search functionality is not giving results even though it has matches.
      But It's working fine in 10.x(http://nightly2.sakaiproject.org:8081/portal), 2.9.3(local environment)

      Attached videos can be opened in VLC player.

      This is specific to the box in rwiki. If search.enable=false, then it works, but if search.enable=true then it won't work unless you also set wiki.fullsearch=false. However setting that means that results won't appear in the search tool. See the comments for the reason why.

      So short answer
      Default. search.enable=false, wiki.fullsearch=true = Built in wiki search works, regular search doesn't work
      Setting search.enable=true, wiki.fullsearch=true = Context search in wiki doesn't work, regular search works for wiki and other tools
      Setting search.enable=true, wiki.fullsearch=false = Context search in wiki works, regular search doesn't search wiki but works for other tools

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  maintenanceteam Core Team
                  Reporter:
                  chaitanya.cheekate Kumar Ch
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  9 Start watching this issue

                  Dates

                  • Created:
                    Updated:

                    Git Source Code