Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-27802

Forums does not work on HSQLDB

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: CLOSED
    • Priority: Critical
    • Resolution: Won't Fix
    • Affects Version/s: 10.2
    • Fix Version/s: None
    • Component/s: Forums Tool
    • Labels:
      None
    • Environment:
      nightly 10.x nightly2.sakaiproject.org:8081

      Description

      From what I've heard, this may be related to Forums interacting with HSQLDB, which is what is running on nightly 10.x, port 8081. I cannot reproduce locally on MySQL.

      1) As a student, create a new conversation and post. You get a friendly message "Alert: An error has occurred while posting a conversation."

      2) The conversation appears to be there, so click on it, and you get a bug report screen.

      I've enclosed a stack trace in a text file, but this might be from step 2.

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  • Assignee:
                    relong Bob Long
                    Reporter:
                    ncaidin Neal Caidin
                  • Votes:
                    0 Vote for this issue
                    Watchers:
                    3 Start watching this issue

                    Dates

                    • Created:
                      Updated:
                      Resolved:

                      Git Integration