Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-32176

Upgrade to latest version of tomcat (8.0.41)

    Details

    • 11 status:
      Resolved

      Description

      Nightlies should be updated to latest version of tomcat which is currently 8.0.41

      Mostly for https://bz.apache.org/bugzilla/show_bug.cgi?id=59151 but there's probably other good fixes and security patches in here.

      This currently is going to require the documentation.

      To get Sakai to startup fast and without warnings, you must modify the default conf/context.xml file to include.

      --- conf/context.xml	2017-01-18 17:25:44.000000000 -0500
      +++ conf/context.xml	2017-02-10 09:08:37.985989229 -0500
      @@ -33,4 +31,8 @@
           <!--
           <Valve className="org.apache.catalina.valves.CometConnectionManagerValve" />
           -->
      +    <JarScanner scanClassPath="false">
      +    	<JarScanFilter defaultPluggabilityScan="false" />
      +    </JarScanner>
      +
       </Context>
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  jonespm Matthew Jones
                  Reporter:
                  jonespm Matthew Jones
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Git Source Code