Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-33564

External Tools is very slow

    Details

    • Type: Bug
    • Status: Verified
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 12.0
    • Fix Version/s: 12.0, 19.0
    • Component/s: BasicLTI
    • Labels:
    • 12 status:
      Resolved
    • Test Plan:
      Hide

      I'm not sure we can test this completely because the bug only is noticeable to the user when there are 1000s of sites in the system. However it is worth checking that the tool still works correctly.

      • Create 2 sites ( they can just be empty).
      • Using the sites tool in the Administration Workspace, find each site in turn and edit it. Add a site property to each of them with a name of 'Department' and set the value to be different on each site (eg One/Two), but the value should be a word.
      • Create a new LTI tool. The tool doesn't have to work just exist. This can be done in the External Tools tool in the Administration Workspace.
      • Add the the tool to both of the newly created Sites (Tool Links panel of External Tools). You need the Site IDs of the sites todo this from the Administration Workspace.

      Now check that the Department column is showing the entered site properties and check that typing one of the search values into the search box in the Department column header and hitting enter correctly filters down the table.

      Show
      I'm not sure we can test this completely because the bug only is noticeable to the user when there are 1000s of sites in the system. However it is worth checking that the tool still works correctly. Create 2 sites ( they can just be empty). Using the sites tool in the Administration Workspace, find each site in turn and edit it. Add a site property to each of them with a name of 'Department' and set the value to be different on each site (eg One/Two), but the value should be a word. Create a new LTI tool. The tool doesn't have to work just exist. This can be done in the External Tools tool in the Administration Workspace. Add the the tool to both of the newly created Sites (Tool Links panel of External Tools). You need the Site IDs of the sites todo this from the Administration Workspace. Now check that the Department column is showing the entered site properties and check that typing one of the search values into the search box in the Department column header and hitting enter correctly filters down the table.

      Description

      In a deployment with lots of site the LTI Admin Tool (External Tools) deployed in the Administration Workspace is very slow on the Tool Links page. We have been seeing load times of seconds.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  csev Charles Severance
                  Reporter:
                  buckett Matthew Buckett
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Git Source Code