Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-35385

Short answer is escaping the output

    Details

    • 11 status:
      Resolved
    • Previous Issue Keys:
      SAM-2878
    • Test Plan:
      Hide

      -Create an assessment

      • Add a short answer, click the rich text editor by the model short answer and add some formatted text for the model question
      • Publish the assessment and take it as a student
      • As instructor go to the scores, select that student
      • Expected, model answer is shown formatted as it was on the screen during creation
      • Actual, it shows the formatting codes (like <font>)
      Show
      -Create an assessment Add a short answer, click the rich text editor by the model short answer and add some formatted text for the model question Publish the assessment and take it as a student As instructor go to the scores, select that student Expected, model answer is shown formatted as it was on the screen during creation Actual, it shows the formatting codes (like <font>)

      Description

      After the fix on SAM-2771, the short answer was moved into the body, but it's escaping HTML characters in the output. This looks like a quick fix but I just wanted it as a separate ticket since it wasn't related or as critical as the original error.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  Sristi Sristi Shrestha
                  Reporter:
                  jonespm Matthew Jones
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Git Source Code