Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-36618

Samigo autosave doesn't work when taking an assessment from a link

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: RESOLVED
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.8.3, 2.8.x, 2.9.0, 10.0
    • Fix Version/s: 2.9.0
    • Labels:
      None
    • 2.9 Status:
      Resolved
    • Previous Issue Keys:
      SAM-1707

      Description

      When taking an assessment from a link (in the email or the "assessments released to tab"), the "autoSave" feature (which is by default not enabled) either doesn't work reliably or results in error messages being displayed such as the message in the screenshot attached.

      I've also had a report of it working on some types/questions then failing to work on the final question.

      My guess is that the javascript for "SaveFormContentAsync('deliverAssessment') doesn't match up for the link which is "beginTakingAssessment.faces" and causes problems.

      I tested this with the setting

      samigo.autoSave.repeat.milliseconds=30000

      To speed up the autosave and it works great on 2.8/2.9 and trunk if the assessment is started from within the interface.

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  samigoteam SAMIGO TEAM (Inactive)
                  Reporter:
                  jonespm Matthew Jones
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  10 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration