Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-36986

Exported EMI assessments with attachments do not import

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: RESOLVED
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 10.4, 10.5
    • Fix Version/s: 11.0
    • Labels:
      None
    • 10 status:
      Please Merge
    • Previous Issue Keys:
      SAM-2561

      Description

      Images attached to EMI question items do not import/export correctly.

      Case 1:

      Create an EMI
      Attach an image to the first item
      Preview the assessment to verify that the image is shown with the item
      Export the assessment to IMS CP
      The image is not included in the IMS CP package, although there is metadata related to the image in the exportAssessment.xml file.

      Case 2:

      Create a new site
      Use Site Info / Import from Site / Tests & Quizzes to import the assessment created in case 1 above.
      Preview the assessment
      The image is missing.

      Case 3:

      Create a new site
      Use Tests & Quizzes / import from file to import an IMS CP file created by export in 1 above
      Images are not part of the IMS CP zip file so this doesn't work.

      Case 4 (this does work)

      Duplicate site - images are correctly copied across in the assessment.

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  ern Earle R Nietzel
                  Reporter:
                  smarquard Stephen Marquard
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration