Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-37939

Students can't see youtube iframe embed content on Student Content pages

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: RESOLVED
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 10.7, 11.0
    • Fix Version/s: 10.7, 11.0
    • Component/s: Lessons
    • Labels:
      None
    • 10 status:
      Resolved
    • Previous Issue Keys:
      LSNBLDR-554
    • Test Plan:
      Hide
      • Login to Sakai as in instructor
      • Create a site with Lessons and at least one student
      • Add a Student content section
      • Add a Student content page (in 11 you have to add it separately)
          • In another window
      • Go to youtube, pick a video
      • Click sharing->embed, copy the iframe link
          • Go back to the Sakai window
      • Click on "Embed content"
      • Add the iframe link here, save it
      • Logout of Sakai or login as a student on another browser
      • Expected, student will see the content
      • Actual student doesn't see any content

      If you add the URL as the embed link (rather than this iframe link) it works.

      Show
      Login to Sakai as in instructor Create a site with Lessons and at least one student Add a Student content section Add a Student content page (in 11 you have to add it separately) In another window Go to youtube, pick a video Click sharing->embed, copy the iframe link Go back to the Sakai window Click on "Embed content" Add the iframe link here, save it Logout of Sakai or login as a student on another browser Expected, student will see the content Actual student doesn't see any content If you add the URL as the embed link (rather than this iframe link) it works.

      Description

      If you go to youtube and pick any video, say

      https://www.youtube.com/watch?v=hCeWr3kkhMo

      And select share->embed you get a link

      <iframe width="560" height="315" src="https://www.youtube.com/embed/hCeWr3kkhMo" frameborder="0" allowfullscreen></iframe>
      

      This link when used as "Insert Embed Content" on an "Student Content" page (say an instructors) will display the video for the instructor, but all students will either not see it or if it's the only content get an error that no items are visible.

      If the URL to the youtube is used as the embed link everything works fine. This also works if the page is not a student content page.

      It seems like a permission error similar to LSNBLDR-529 but not the same thing.

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  hedrick Charles Hedrick
                  Reporter:
                  jonespm Matthew Jones
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration