Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-38135

Embed youtube video / 404 error

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: RESOLVED
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 10.7
    • Fix Version/s: 10.8 [Tentative]
    • Component/s: Lessons
    • Labels:
      None
    • Environment:
      10x maint branch
    • 11 status:
      Resolved
    • 10 status:
      Resolved
    • Previous Issue Keys:
      LSNBLDR-642

      Description

      When attempting to embed a youtube video using embed content on page, the item is added with a deleted heading and displays as HTTP 404(see screenshot).

      Example youtube video:
      https://www.youtube.com/watch?v=mO2KIkFuKdg

      For people running 10.7, a quick fix can be found at
      https://crucible.sakaiproject.org/changelog/Sakai.Git?cs=0e32509f1a2b95296e364e056e3dc6ce2b84f86b

      If you just do the fix in SimplePageBean there, it will fix most of the symptoms in 10.7. (The show-page.js patch is more relevant to 11 and 12.) More changes will be in 10.8. Feel free to take all of them, but that one change to SimplePageBean is easy to do and will let you see Youtube again.

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  • Assignee:
                    hedrick Charles Hedrick
                    Reporter:
                    drramsey Derek Ramsey
                  • Votes:
                    0 Vote for this issue
                    Watchers:
                    2 Start watching this issue

                    Dates

                    • Created:
                      Updated:
                      Resolved:

                      Git Integration