Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-38772

Neo prefix not used in HTML files created with Resources tool

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: RESOLVED
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.9.x, 10.2
    • Fix Version/s: 10.6
    • Component/s: Kernel
    • Labels:
      None
    • 10 status:
      Resolved
    • Previous Issue Keys:
      KNL-1327

      Description

      The tool.css import in the header fragment of an HTML doc created with the resources tool does not account for the neo prefix.

      Because of the issue identified in SAK-27873, portal.inline.experimental=false needs to be set to reproduce this in a trunk instance.

      1. Navigate to the resources tool of a site.
      2. Click Actions -> Create HTML Page
      3. Add some content to the editor then click Continue.
      4. Give the page a name then click Finish.
      5. Link the page with the web content tool or download the html file if content.html.forcedownload is true.

      If you look at your browser's JavaScript console when viewing the html doc you will see "Failed to load resource: the server responded with a status of 404 (Not Found)" for the tool.css file.
      If you download the file and open it up in a text editor the neo prefix will be missing from the path to the tool.css file.

        Gliffy Diagrams

          Zeplin

            Attachments

              Activity

                People

                Assignee:
                buckett Matthew Buckett
                Reporter:
                ktakacs Kevin Takacs
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    Git Integration