Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-39747 Upgrade to jsp-api 2.2
  3. SAK-39847

Some tools still broken by jsp-api upgrade

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Verified
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 10.0
    • Fix Version/s: 10.0
    • Component/s: Kernel
    • Labels:

      Description

      In trunk, a few tools are still broken because the they have a different version declared than what's in shared.

      At least for signup, it looks like removing the dependency entirely or making it provided works. Removing the version 'should' work if it's not an indie. This probably should be better communicated to contrib tool developers as well because the thread "Trunk broken? By messageforums and/or jsf?" isn't very clear that there is action needing to be taken. After an svn up on trunk.

      I can confirm on trunk nightly that tools in this list such as postem and gradebook aren't working.

      find . -name "pom.xml" | xargs grep -A 2 jsp-api | grep -B 1 2.0

      ./reference/library/target/war/work/org.sakaiproject/sakai-fck-connector/META-INF/maven/org.sakaiproject/sakai-fck-connector/pom.xml: <artifactId>jsp-api</artifactId>
      ./reference/library/target/war/work/org.sakaiproject/sakai-fck-connector/META-INF/maven/org.sakaiproject/sakai-fck-connector/pom.xml- <version>2.0</version>

      ./gradebook/app/standalone-app/pom.xml: <artifactId>jsp-api</artifactId>
      ./gradebook/app/standalone-app/pom.xml- <version>2.0</version>

      ./gradebook/app/business/pom.xml: <artifactId>jsp-api</artifactId>
      ./gradebook/app/business/pom.xml- <version>2.0</version>

      ./gradebook/app/ui/pom.xml: <artifactId>jsp-api</artifactId>
      ./gradebook/app/ui/pom.xml- <version>2.0</version>

      ./syllabus/syllabus-app/pom.xml: <artifactId>jsp-api</artifactId>
      ./syllabus/syllabus-app/pom.xml- <version>2.0</version>

      ./samigo/samigo-app/pom.xml: <artifactId>jsp-api</artifactId>
      ./samigo/samigo-app/pom.xml- <version>2.0</version>

      ./jsf/pom.xml: <artifactId>jsp-api</artifactId>
      ./jsf/pom.xml- <version>2.0</version>

      ./jsf/myfaces-widgets/pom.xml: <artifactId>jsp-api</artifactId>
      ./jsf/myfaces-widgets/pom.xml- <version>2.0</version>

      ./podcasts/podcasts/pom.xml: <artifactId>jsp-api</artifactId>
      ./podcasts/podcasts/pom.xml- <version>2.0</version>

      ./user/user-tool-prefs/tool/pom.xml: <artifactId>jsp-api</artifactId>
      ./user/user-tool-prefs/tool/pom.xml- <version>2.0</version>

      ./site-manage/site-association-tool/tool/pom.xml: <artifactId>jsp-api</artifactId>
      ./site-manage/site-association-tool/tool/pom.xml- <version>2.0</version>

      ./osp/jsf/widgets/pom.xml: <artifactId>jsp-api</artifactId>
      ./osp/jsf/widgets/pom.xml- <version>2.0</version>

      ./osp/presentation/tool-lib/pom.xml: <artifactId>jsp-api</artifactId>
      ./osp/presentation/tool-lib/pom.xml- <version>2.0</version>

      ./osp/common/tool-lib/pom.xml: <artifactId>jsp-api</artifactId>
      ./osp/common/tool-lib/pom.xml- <version>2.0</version>

      ./osp/wizard/tool/pom.xml: <artifactId>jsp-api</artifactId>
      ./osp/wizard/tool/pom.xml- <version>2.0</version>

      ./rwiki/rwiki-tool/tool/pom.xml: <artifactId>jsp-api</artifactId>
      ./rwiki/rwiki-tool/tool/pom.xml- <version>2.0</version>

      ./metaobj/metaobj-util/tool-lib/pom.xml: <artifactId>jsp-api</artifactId>
      ./metaobj/metaobj-util/tool-lib/pom.xml- <version>2.0</version>

      ./metaobj/metaobj-tool/tool/pom.xml: <artifactId>jsp-api</artifactId>
      ./metaobj/metaobj-tool/tool/pom.xml- <version>2.0</version>

      ./help/help-tool/pom.xml: <artifactId>jsp-api</artifactId>
      ./help/help-tool/pom.xml- <version>2.0</version>

      ./textarea/FCKeditor/connector/pom.xml: <artifactId>jsp-api</artifactId>
      ./textarea/FCKeditor/connector/pom.xml- <version>2.0</version>

      ./sections/sections-app-util/pom.xml: <artifactId>jsp-api</artifactId>
      ./sections/sections-app-util/pom.xml- <version>2.0</version>

      ./postem/postem-app/pom.xml: <artifactId>jsp-api</artifactId>
      ./postem/postem-app/pom.xml- <version>2.0</version>

      ./profile/profile-app/pom.xml: <artifactId>jsp-api</artifactId>
      ./profile/profile-app/pom.xml- <version>2.0</version>

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                aaronz Aaron Zeckoski (Inactive)
                Reporter:
                jonespm Matthew Jones
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code