Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-39866

Create compatilbity patch for IE9

    Details

    • Type: (Deprecated) Contributed Patch
    • Status: CLOSED
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.6.x, 2.7.x
    • Fix Version/s: 2.6.x, 2.7.x, 2.8.x
    • Component/s: Kernel
    • Labels:
    • Property addition/change required:
      Yes
    • Previous Issue Keys:
      KNL-697

      Description

      Just incase we need the patch to resolve SAK-20058 (and I keep getting contacted about it), I created a better version of the patch for 2.5.x (SAK-16074) to automatically enable compatibility mode for IE9 in the request filter.

      This should work, but I haven't tested if the property name is valid or not yet. I also don't have easy access to IE9. So if someone else has an easier way of patching and running this it would be great.

      The property is "sakai.X-UA-Compatible", and by default it will not enable any compatibility. i also attached a patch for the config project because i believe a default of
      sakai.X-UA-Compatible=IE=EmulateIE8

      to emulate IE8.

        Gliffy Diagrams

          Attachments

          1. KNL-697-config.patch
            0.7 kB
            Matthew Jones
          2. KNL-697-kernel.patch
            2 kB
            Matthew Jones

            Issue Links

              Activity

                People

                • Assignee:
                  arwhyte Anthony Whyte
                  Reporter:
                  jonespm Matthew Jones
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Git Source Code