Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-40065

Deprecate and Remove support for IMS LTI 2.0

    Details

    • Type: Bug
    • Status: Open
    • Priority: Blocker
    • Resolution: Unresolved
    • Affects Version/s: 19.0 [Tentative]
    • Fix Version/s: None
    • Component/s: BasicLTI
    • Labels:
      None
    • Test Plan:
      Hide

      Please add a Test Plan here.

      Show
      Please add a Test Plan here.

      Description

      At this point, all the major vendors that support LTI 2.0 have quietly decided to move away from LTI 2.0 and towards LTI 1.3 and ContentItem and follow-ons.

      LTI 2.0 has a few good features and a lot of bad ideas.  Sakai's LTI 2.0 (and almost LTI 2.1) is one of the best in the industry and one of only two certified LTI 2.0 LMS's.

      But even with all that it is a bunch of code that if never used is a liability for security and maintenance - and as new features like LTI 1.3, its services, and new follow-on specs emerge - it is nice to clean up a large amount of code to make space for new stuff.

      So at this point LTI 2.0 is deprecated in Sakai 12.x and will be removed by the next release of Sakai.  

      If you have any concerns - or tools that require LTI 2.0 - please note them in this JIRA.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                csev Charles Severance
                Reporter:
                csev Charles Severance
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Git Source Code