Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-40088

Error from roster when adding member to site via webservice

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: RESOLVED
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 11.5 [Tentative], 12.2, 19.0
    • Fix Version/s: 12.4, 19.0
    • Component/s: Roster
    • Labels:
      None
    • 12 status:
      Resolved
    • 11 status:
      Please Merge
    • Test Plan:
      Hide

      I was able to reproduce this with the addMemberToSiteWithRole call. Seems pretty straightforward to fix.

      Show
      I was able to reproduce this with the addMemberToSiteWithRole call. Seems pretty straightforward to fix.

      Description

      I'm adding members to site and roster is throwing this error a lot. It looks like from SAK-30775 that site id should be checked for null first before calling?

      05-Jun-2018 13:52:45.330 WARN [http-nio-8080-exec-8] org.sakaiproject.roster.impl.SakaiProxyImpl.getSite site not found: null
      

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  • Assignee:
                    jonespm Matthew Jones
                    Reporter:
                    jonespm Matthew Jones
                  • Votes:
                    0 Vote for this issue
                    Watchers:
                    2 Start watching this issue

                    Dates

                    • Created:
                      Updated:
                      Resolved:

                      Git Integration