Currently if you want to load some sakai.properties with either getStringList() or getPatternList(), the sakai.property must be defined as a single property with comma separated values:
If your list of values is really long (long text values, long or numerous regex patterns, etc.), the resulting property can be difficult to read and manage. Although the .count style of defining sakai.properties is "old", it can be really beneficial for situations like these to clean things up:
It's a relatively minor change to getStringList() (which is also used by getPatternList()) to support both styles of defining sakai.properties by simply using the existing getStrings() method rather than getString().