Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-40896

PostEm: Missing for attribute in label

    XMLWordPrintable

    Details

    • 20 status:
      Verified
    • Test Plan:
      Hide

      Please add a Test Plan here.

      Show
      Please add a Test Plan here.

      Description

      I saw  several  of the following  errors (I tested both uploading and selecting files from resources for Postem while testing SAK-40882):

      06-Nov-2018 19:40:04.203 WARN [http-nio-20013-exec-56] org.apache.myfaces.renderkit.html.HtmlLabelRenderer.encodeBegin Attribute 'for' of label component with id _idJsp1:_idJsp17 is not defined
      06-Nov-2018 19:40:16.723 ERROR [http-nio-20013-exec-56] javax.faces.webapp._ErrorPageWriter.handleThrowable An exception occurred
      

       

      One of my titles for a postem had an underscore in it and when I clicked to upload/link a file, I received a stack trace. I tried to reproduce it, but was unable to, which is why I left this at major. Maybe a dev can tell from the stacktrace?

      Site: DEWT_927Y_1032

        Gliffy Diagrams

          Zeplin

            Attachments

            1. 20x_postem_26Mar2020.gif
              20x_postem_26Mar2020.gif
              23 kB
            2. 26Mar2020_PostEm.mp4
              4.19 MB
            3. postem_stacktrace.txt
              8 kB
            4. postem error.gif
              postem error.gif
              24 kB

              Activity

                People

                Assignee:
                maintenanceteam Core Team
                Reporter:
                agschmidt Andrea Schmidt
                Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    Git Integration