Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-41112

Site duplication / links between Lessons and Forums are incorrect

    Details

    • Type: Bug
    • Status: CLOSED
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 12.5, 19.0, 20.0 [Tentative]
    • Fix Version/s: 12.6, 19.0, 20.0 [Tentative]
    • Component/s: Lessons, Site Info
    • Labels:
    • Environment:
      Nightly 12/19/trunk
    • 19 status:
      Resolved
    • 12 status:
      Resolved
    • Test Plan:
      Hide

      Please add a Test Plan here.

      Show
      Please add a Test Plan here.

      Description

      To replicate:

      1. Create a site that has a Forums and Lessons
      2. In the Lessons tool, create a link to a forum topic
      3. As instructor/admin, select the link from Lessons to the topic and make a conversation posting
      4. Once saved, go to Site Info->Duplicate site
      5. On the new site, confirm the Forums are in draft status
      6. In Lessons, the link to the forums should link to the new sites forum and say *Not published, not visible to students.

      Instead, it is pointing to the original sites Forums tool.  

      Site Info -> Import from site does not exhibit this behavior, only Duplicate Site.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  maintenanceteam Core Team
                  Reporter:
                  drramsey Derek Ramsey
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Git Source Code