Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-41938

Forum Tool: Check boxes are not associated to parent label

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: OPEN
    • Priority: Critical
    • Resolution: Unresolved
    • Affects Version/s: 19.1, 20.0 [Tentative]
    • Fix Version/s: None
    • Component/s: Accessibility, Forums Tool
    • Labels:
      None
    • Environment:
      Initially found in Illinois State University Sakai 19.1 environment
    • Test Plan:
      Hide
      1. Navigate to Forum tool.
      2. Navigate to Forum Settings
      3. using the tab key, tab through form field until you reach the First check box under "Forum Posting." Check box does not announce the Forum Posting heading as the group label.

      Show
      Navigate to Forum tool. Navigate to Forum Settings using the tab key, tab through form field until you reach the First check box under "Forum Posting." Check box does not announce the Forum Posting heading as the group label.

      Description

      The check boxes under Forum Posting in the forums tool are not associated with the over arching parent label (in this case a heading). As a screen reader user tabs through the form fields the headings before the group of check boxes are skipped over and are not announced when the user moves into the form control group. This is difficult for screen reader users to know what the check boxes refer to as a group. 

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                maintenanceteam Core Team
                Reporter:
                jbbeth1 Jen Bethmann
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Git Source Code