Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-42040

LTI ext_sakai_encrypted_session is not adding the session to header

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Awaiting Review
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 20.0 [Tentative]
    • Fix Version/s: None
    • Component/s: BasicLTI
    • Labels:
      None
    • Test Plan:
      Hide
      1. Use External tools to add Tsugi as a test LTI tool.
        1. https://www.tsugi.org/lti-test/tool.php
        2. key: 12345
        3. secret: secret
      2. Then goto the tool properties and add the property:imsti.ext_sakai_encrypted_session = true
      3. Then go back to the tool in the site and launch it.
      4. Expect to see a splash screen warning me about the session
      Show
      Use External tools to add Tsugi as a test LTI tool. https://www.tsugi.org/lti-test/tool.php key: 12345 secret: secret Then goto the tool properties and add the property:imsti.ext_sakai_encrypted_session = true Then go back to the tool in the site and launch it. Expect to see a splash screen warning me about the session

      Description

      Attempting to get the session when using the feature related to property:
      imsti.ext_sakai_encrypted_session = true
       

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                csev Charles Severance
                Reporter:
                ern Earle R Nietzel
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Git Source Code