Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-43424

Forums: After submitting grade and coming back into forums, the grading screen displays and can't be closed

    XMLWordPrintable

    Details

    • Test Plan:
      Hide
      1. Add forums and gradebook to your site
      2. Create a gradebook item
      3. Click on Forums
      4. Click Forum Settings for the default forum
      5. Link the gradebook item and save
      6. As the student, submit a post to the default topic under the default forum
      7. As the instructor, click More - > Grade beside the Forum 
      8. Click on Grade for that student
      9. Submit a grade for that student (now the Forum / Statistics & Grading / Forum Title page displays again)
      10. Click on Gradebook - verify grade is there
      11. Click on Forums in the menu

      Currently an empty grading screen displays and can't be closed

      Expected: The main Forums page to display (if not possible, then at least the Forum / Statistics & Grading / Forum Title where the user can at least get out of the page more easily)

      Show
      Add forums and gradebook to your site Create a gradebook item Click on Forums Click Forum Settings for the default forum Link the gradebook item and save As the student, submit a post to the default topic under the default forum As the instructor, click More - > Grade beside the Forum  Click on Grade for that student Submit a grade for that student (now the Forum / Statistics & Grading / Forum Title page displays again) Click on Gradebook - verify grade is there Click on Forums in the menu Currently an empty grading screen displays and can't be closed Expected: The main Forums page to display (if not possible, then at least the Forum / Statistics & Grading / Forum Title where the user can at least get out of the page more easily)

      Description

      I think this must be some kind of caching issue on the server. After the first incident, I cleared my cache which didn't help any. This may also end up affecting 20x and 19x, but can't test until SAK-43343 is merged.

      If the instructor grades a student by going to Forum Title - > More - > Grade, grades the student and submits the grade, the Forum / Statistics & Grading / Forum Title page displays again. If the user clicks on something else in the menu now, (gradebook for example), and then clicks on Forums in the menu again, an empty grading screen displays. 

      It is not possible to close this grading screen using the 'X'. Clicking the 'X' to close causes all sorts of weird behavior.

      The workaround is to click the "Forums" link at the top of the page BEFORE clicking the 'X', trying to close the screen. Once the 'X' has been clicked, the screen is locked. Only a refresh of the page will get the user out of the screen then.

      Of the 2 videos, #1 is after I cleared my cache and re-entered the site. #2 is after creating the new forum (this one with a rubric) and having the student post, then grading that one. #2 shows the process of grading, submitting the grade, going to the gradebook, clicking on forums again and the grading screen displaying.

       

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  Unassigned Unassigned
                  Reporter:
                  agschmidt Andrea Schmidt
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration