Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-43623

Samigo answer is correct but score is 0 with single question test and multiple tabs open

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: OPEN
    • Priority: Critical
    • Resolution: Unresolved
    • Affects Version/s: 12.7, 19.4, 20.0, 21.0 [Tentative]
    • Fix Version/s: None
    • Labels:
      None
    • Test Plan:
      Hide
      • create test with a single multiple-choice question
      • create another test with a single multiple-choice question
      • login as a student
      • open two browser tabs
      • in each tab go to the main samigo index page
      • in tab 1, click the 1st test, and click "begin assessment" (but don't save or submit yet)
      • in tab 2, click the 2nd, but do not begin it
      • in tab 1, select the correct answer and click submit for grading
      • in tab 1, click the "confirm submit for grading" button
      • in tab 1, you should be shows a "Data Discrepancy" error
      • in tab 1, retake test 1
      • in tab 1, select the correct answer, submit for grading, confirm submit for grading
      • as the instructor, check the scores for test 1
      • the submission will be graded 0
      • click the user's name to view the test details
      • the answer is correct, but the score is 0
      Show
      create test with a single multiple-choice question create another test with a single multiple-choice question login as a student open two browser tabs in each tab go to the main samigo index page in tab 1, click the 1st test, and click "begin assessment" (but don't save or submit yet) in tab 2, click the 2nd, but do not begin it in tab 1, select the correct answer and click submit for grading in tab 1, click the "confirm submit for grading" button in tab 1, you should be shows a "Data Discrepancy" error in tab 1, retake test 1 in tab 1, select the correct answer, submit for grading, confirm submit for grading as the instructor, check the scores for test 1 the submission will be graded 0 click the user's name to view the test details the answer is correct, but the score is 0

      Description

      Samigo answer is correct but score is 0 with single question test and multiple tabs open

      I found this while testing the patch for SAK-34373 in 12.7, which is fixed for tests that have more than one question. But this issue occurs where there is only 1 question in the test.

      It also happens on the nightly master qa server, which already has the SAK-34373 patch.

      note - I included 12.7 and 19.7 in the affects version because I found the problem in 12.7 after applying the patch for SAK-34373.

        Gliffy Diagrams

          Zeplin

            Attachments

              Issue Links

                Activity

                  People

                  Assignee:
                  maintenanceteam Core Team
                  Reporter:
                  austinUH Austin
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                    Dates

                    Created:
                    Updated:

                      Git Integration