Uploaded image for project: 'Sakai'
  1. Sakai
  2. SAK-44857

When setting the entry description in LTI 1.3 Deep Link it does not make it into Lessons

    XMLWordPrintable

    Details

    • 21 Status:
      Verified
    • 20 status:
      Verified
    • Test Plan:
      Hide

      Install an LTI 1.1 and LTI 1.3 Tsugi store.   Add Learning App using 1.1 and 1.3.  When adding the learning app - change the title and description before sending the tool back to Lessons for installation.  The tool-provided title and description should appear in Lessons as requested by the tool for both the LTI 1.1 and LTI 1.3 placed tools.  Then change both the title using the Lessons edit interface.  Then launch the tool in debug mode and make sure the updated title and description are included in the launch.

      Show
      Install an LTI 1.1 and LTI 1.3 Tsugi store.   Add Learning App using 1.1 and 1.3.  When adding the learning app - change the title and description before sending the tool back to Lessons for installation.  The tool-provided title and description should appear in Lessons as requested by the tool for both the LTI 1.1 and LTI 1.3 placed tools.  Then change both the title using the Lessons edit interface.  Then launch the tool in debug mode and make sure the updated title and description are included in the launch.

      Description

      Install an LTI 1.1 and LTI 1.3 Tsugi store.   Add Learning App using 1.1 and 1.3.  When adding the learning app - change the title and description before sending the tool back to Lessons for installation.  The tool-provided title and description appear in the right places in the LTI 1.1 placed tool - but when the tool is placed using 1.3, the title is correct but the description is a copy of a title rather than the description suggested by the tool.

      This turns out to be an error in Tsugi - Sakai is working correctly.  But I am going to make a patch to Sakai to (a) check for empty values of the title and description more reliably and (b) remove the "TODO" comment in Sakai where I wondered why this was not coming back form Tsugi.  I think the confusion had to do with Tsugi working with a draft spec at one point.

      This is fixed in Tsugi as of https://github.com/tsugiproject/tsugi-php/commit/0bd9131dd69b72ab56e718dc7228be3cca518d8f

        Gliffy Diagrams

          Zeplin

            Attachments

            1. 21x_Edit_LTI_Tools.gif
              21x_Edit_LTI_Tools.gif
              17 kB
            2. lti_descriptions.gif
              lti_descriptions.gif
              6 kB
            3. SAK-44857-Broken.png
              SAK-44857-Broken.png
              172 kB
            4. SAK-44857-Fixed.png
              SAK-44857-Fixed.png
              404 kB

              Issue Links

                Activity

                  People

                  Assignee:
                  csev Charles Severance
                  Reporter:
                  csev Charles Severance
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved:

                      Git Integration