Uploaded image for project: 'Samigo'
  1. Samigo
  2. SAM-921

Improvement: No Assessment Templates/Types

    Details

    • Type: Contributed Patch
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.0, 2.6.1, 2.6.2
    • Fix Version/s: 2.8.0
    • Component/s: Authoring
    • Labels:
      None

      Description

      Since teachers keep missing out on the settings (ALL THE TIME) when making tests, i.e. making tests that are anonymous when they wanna be able to grade them, setting up timed tests that fails to save cause no time limit is set etc etc We decided to remove the possibility to not make your own settings. We removed preconfigured tests and quick creation button. Only thing left: Name a test and create it > Do your settings before publish. The fix is divided into three parts.

      Changeset 636: Removed Quick-button
      Changeset 679: Removed dropdown with predefined testtypes
      Changeset 687: Removed testtypes from subnavigational levels

        Gliffy Diagrams

          Attachments

          1. Changeset636.diff
            1 kB
          2. Changeset679.diff
            3 kB
          3. Changeset687.diff
            8 kB
          4. SAM-921.patch
            11 kB

            Issue Links

              Activity

              ottenhoff Sam Ottenhoff added a comment -

              I agree with Jan that removing the assessment templates would dramatically reduce confusion for Sakai instructors. We also find that instructors run into serious confusion regarding anonymous assessments and timed assessments.

              maka Michael "Maka" Gradin added a comment -

              We see the same things at Rutgers and were discussing removing the templates entirely when I came across this ticket.

              lydial@stanford.edu Lydia Li added a comment -

              At Stanford, we deleted all the predefined templates. We still gave instructors the option to create their own templates.

              ottenhoff Sam Ottenhoff added a comment -

              Lydia,

              Would you accept a patch against trunk that would allow a sakai.properties setting to remove the display of "Assessment Types"?

              --Sam

              lydial@stanford.edu Lydia Li added a comment -

              Sure.

              ottenhoff Sam Ottenhoff added a comment -

              Patch against trunk attached.

              New sakai.properties setting is called "samigo.showAssessmentTypes"

              If set to false, it should be hidden in all JSP files. New permission is added to TemplateBean: showAssessmentTypes

              I also added a simple SQL command for all users that want to begin hiding the AssessmentTypes tool and to make every IsInstructorEditable setting for existing assessments set to true.

              ottenhoff Sam Ottenhoff added a comment -

              Samigo Team,

              Is this patch likely to be accepted before the fall term (e.g., in next couple of weeks)? If not, we will create a branch, but it would be nice to get some of these features that don't affect default behavior into samigo-trunk.

              ktsao Karen Tsao added a comment -

              Sam,

              I can merge this into trunk sometime next week. However, because this is a new feature, we probably won't get this into 2.7.x. Is this OK with you?

              Thanks,
              Karen

              ottenhoff Sam Ottenhoff added a comment -

              Absolutely: a 2.8 target is great. Thanks

              ktsao Karen Tsao added a comment -

              Sam,

              For the Quick create feature, you can disable it by setting samigo.samliteEnabled=false. Therefore, I won't merge your Changeset 636. Does this sound ok to you?

              Thanks,
              Karen

              ottenhoff Sam Ottenhoff added a comment -

              Hi Karen,

              Sorry for the confusion. My patch against trunk is called SAM-921.patch. The Changeset patches comes from Jan, and I believe are against 2.6.2.

              My patch should not touch samlite functionality.

              Thanks,
              Sam

              ktsao Karen Tsao added a comment -

              I see. Thanks for clarifying.

              Karen

              ktsao Karen Tsao added a comment - - edited

              To summarize what this JIRA does:

              1. Introduce a new sakai.properties setting samigo.showAssessmentTypes.
              2. If samigo.showAssessmentTypes is not set or set to true, everything works the same as before. This is the OOTB behavior.
              3. If samigo.showAssessmentTypes is set to false, following things should happen:
              a. The heading should be changed from "Assessments | Assessments Types | Question Pools" to "Assessments | Question Pools". This should be seen in all the pages (eg, edit assessments, question pools, scores page, etc).
              b. In the main page, the "Choose assignment type (optional)" dropdown box should be removed from New Assessments section.
              c. In the Assessment Settings page, the "Assessment Type Information" setting should be removed.

              ktsao Karen Tsao added a comment -

              Revision 80902.

              ktsao Karen Tsao added a comment -

              One more checkin: r81335.

              ktsao Karen Tsao added a comment -

              r82717 and r82718.

              ktsao Karen Tsao added a comment -

              For 2.8.x:

              svn commit -m "SAM-921"
              Sending docs/sakai.properties
              Transmitting file data .
              Committed revision 82719.

              arwhyte Anthony Whyte added a comment -

              in 2.8.x

              mclare Matt Clare added a comment -

              I added the line samigo.showAssessmentTypes=false to the sakai.properties of the 2.8 version of the sakai-demo HSQL system and got a stack dump in Tests & Quizzes. Is this to be expect?

              Here's the dump:

              org.sakaiproject.portal.api.PortalHandlerException: java.lang.IllegalArgumentException: Unable to find registered context for tool with ID sakai.samigo
              at org.sakaiproject.portal.charon.SkinnableCharonPortal.doGet(SkinnableCharonPortal.java:862)
              caused by: java.lang.IllegalArgumentException: Unable to find registered context for tool with ID sakai.samigo
              at org.sakaiproject.tool.impl.ActiveToolComponent$MyActiveTool.forward(ActiveToolComponent.java:508)
              at org.sakaiproject.portal.charon.SkinnableCharonPortal.forwardTool(SkinnableCharonPortal.java:1429)
              at org.sakaiproject.portal.charon.handlers.ToolHandler.doTool(ToolHandler.java:204)
              at org.sakaiproject.portal.charon.handlers.ToolHandler.doGet(ToolHandler.java:96)
              at org.sakaiproject.portal.charon.SkinnableCharonPortal.doGet(SkinnableCharonPortal.java:862)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:627)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)

              ottenhoff Sam Ottenhoff added a comment -

              Hi Matt,

              Are you able to enable/disable this error simply by enabling this sakai property?

              I can't replicate your error with Sakai 2.8.0


                People

                • Assignee:
                  jthapa Jasmine Thapa
                  Reporter:
                  jan.bidner@ladok.umu.se Johan Carlsson
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Git Source Code